Developing Visual Studio .NET Applications on Advantech CE.NET Products

Version 1.1
## Revision History

<table>
<thead>
<tr>
<th>Date</th>
<th>Version</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>4/27/05</td>
<td>1.1</td>
<td>Add ADAM-6501 in product list</td>
</tr>
</tbody>
</table>
# Table of Contents

1. Introduction 6

2. Creating a simple .NET application 7
   - Creating a Smart Device Application Project on Emulator 9
   - Creating a Smart Device Application Project on Advantech CE Devices 14

3. Debugging a .NET application 20
1. Introduction

The .NET Compact Framework is a “lite” version of the full, desktop .NET Framework. It includes a compatible subset of the base class libraries of the full .NET Framework, and it throws in a few new ones that are specifically designed for mobile devices. The .NET Compact Framework also has a new implementation of the common language runtime, built from the ground up to run efficiently on small devices that are constrained in both memory and CPU power and which must conserve battery power.

Like the .NET Compact Framework, ASP.NET mobile controls (formerly known as the Microsoft Mobile Internet Toolkit (MMIT)) allows you to build applications for mobile devices. However, .NET Compact Framework applications run on the device as “rich clients” with access to the resources of the device, such as storage and other hardware components. In ASP.NET applications, the only software running on the device is a Web browser.

SQL Server CE is a compact relational database that runs on Windows CE devices. It was first released in 2000 and has already proven its popularity with Windows CE developers prior to the appearance of the .NET Compact Framework. It is upwardly compatible with SQL Server, using compatible data types, and it has a small footprint of only around 800 KB on an ARM processor, which is suitable for constrained devices.

UNO, TPC and ADAM-6501 (Figure 1-1 is a product of UNO family, Figure 1-2 is a product of TPC family, Fig1-3 is ADAM-6501) are 3 series products of Advantech. Both of them have .NET Capabilities, such as ADO.NET, SQL Server CE and so on.

Figure 1-1: UNO2059  Figure 1-2: TPC1560

Figure 1-3: ADAM-6501
2. Creating a simple .NET application

Visual Studio .NET 2003 includes capabilities that allow you to write and debug applications for the .NET Compact Framework. You use exactly the same tools and techniques that you use to develop applications for the full .NET Framework, but you use the .NET Compact Framework base class libraries, which are a subset of those in the full Framework. When testing, you deploy to a real handheld device or to an emulator and debug remotely enjoying the use of full Visual Studio .NET debugging facilities.

You use Visual Studio .NET 2003 to develop applications for the .NET Compact Framework. This new release of Visual Studio .NET adds the capability to develop applications using the .NET Compact Framework and has the advantage of allowing experienced .NET Framework application developers to use their skills to develop applications for smart devices.

Differences between Smart Device and PC Application Projects

Although you use the same environment to create Smart Device projects as you would use to create desktop projects, there are a number of differences that you should be aware of.

- Additional tools are provided for connecting to and debugging on a remote device.

- When debugging your application, you must select a device to run your application on. You may either use a device emulator running on the development computer or a physical device connected to the development computer either directly (by serial or USB) or via a network connection.

- You can generate the CAB file used to distribute your application from within your device project rather than having to create a separate deployment project.

- The classes available to you differ from those available for projects built with the full .NET Framework. The classes available can be found by using the integrated help system or the Visual Studio Object Browser from within your device project. Visual Studio .NET IntelliSense lists only the classes and class members that you may use.
Quick Start

How do you develop/debug a Visual Studio .NET application?

<Step1> Build the connection between UNO and PC via ActiveSync. (Further information about ActiveSync; please refer to “ActiveSync User Guide”.)

<Step2> Install Microsoft Visual Studio .NET 2003 in your PC.

<Step3> Please download “Windows CE utility for Visual studio .NET 2003 Add-on Pack” from below path and install it.


---Create a new .NET Studio project---

<Step4> Select “file”→”New”→”Project”. Select “Visual C# Project in project type; Select “Smart Device Application” in template. Press “OK” button to continue next step.

<Step5> Select “Tools”→”Select Windows CE Device CPU”; select “X86” from the device architecture and click “Configure” button.

<Step6> Select “Windows CE” in the available platforms list and select “Windows Application” in the available project types list.
Creating a Smart Device Application Project on Emulator

1. On the development workstation, launch the Visual Studio .NET 2003 by clicking Start->All Programs->Microsoft Visual Studio .NET 2003->Microsoft Visual Studio .NET 2003. (See Figure 2-1)

![Figure2-1](image1)

2. From the File menu, choose New, and choose Project. (See Figure 2-2)

![Figure2-2](image2)

3. When New Project appears, Select Visual C# Projects in the Project Types pane on the left, and then select Smart Device Application in the Templates pane on the right. Enter SimpleTest as the name of your project in the Name text box at the bottom of the New Project dialog box. Enter the directory where you want to save your application in the Location text box. Click the OK button.
You create a project for smart devices the same way that you create a desktop project. The main difference is that you cannot choose the Project Type (for example, Windows Application or Class Library) until you have chosen a target platform for your project.

You select the language that you will use for your project from the left pane of the New Project dialog box. The right pane of the dialog box lists the Project Templates available for the selected language. You select the Smart Device Application template to create a Smart Device Application project.

NOTE
Visual Studio .NET 2003 supports either the Visual Basic .NET or the C# programming language for Smart Device Application projects.

4. After you click the OK button in the New Project dialog box, you choose the target platform and project type for the application using the Smart Device Application Wizard, as shown in Figure2-4.

The upper-left section of the dialog box lists the available platforms. The right side of the dialog box lists the currently installed devices that will run the application targeting the selected platform type. The lower section of the dialog box lists the project types available for the select target platform, as described in Table2-1. Choose Windows CE in the available platforms list, choose Windows Application in the available project types list, and then click OK.
5. In the **Properties window**, scroll down to the **Size** property, and enter **246, 295**. Then click **Toolbox** on the left (Figure2-5). Using the toolbox, add a **button** control to the center of Form1. Change the button’s **Text property** to **&Exit** (Figure2-6). The form should look like the one shown in Figure2-7.
6. Double-click **Exit** button to create a click-event procedure, and enter the following line of code into the editor (Figure2-8):

```csharp
Application.Exit();
```

Then From the **File** menu, choose **Save All** to save your project.

![Figure2-8](image)

7. From the **Build** menu, choose **Build Solution**. You should see the result as Figure2-9.

![Figure2-9](image)

8. From the **Debug** menu, choose **Start Without Debugging**. The Deploy dialog box shown in Figure2-10 is displayed. This dialog box lists the available devices that support the current project type. Select **Windows CE .NET Emulator**, and click the **Deploy** button. Visual Studio will now build your application and start the emulator.

![Figure2-10](image)

Once the deployment is successful, Visual Studio will start your application on the emulator (Figure2-11). Click the Exit button will Exit from this application.
Creating a Smart Device Application Project on Advantech CE Devices

In order to create a smart device application project on Advantech CE devices, we have to do the following things before we start creating our project:

Visual Studio .NET 2003 is designed to make deploying and debugging applications easy on Pocket PC and other devices running Windows CE 4.1 and later. However, Visual Studio is unable to connect to devices running Windows CE that do not have an ActiveSync connection and cannot dynamically determine the CPU on non-Pocket PC devices. This add-on pack addresses these issues and enables Visual Studio to connect, deploy, and debug any device running Windows CE 4.1 or later.

The Windows CE Utilities for Visual Studio .NET 2003 add-on pack enables connecting through ActiveSync or directly over Ethernet (ActiveSync not required).

2. Make sure that you have installed **ActiveSync 3.5** or later from Microsoft. (You could get the latest version of the tool from Web Site of Microsoft.

Now, Let us begin to create our project.

1. Do the same steps from **step1 to step6** as "Creating reating a Smart Device Application Project on Advantech CE Devices".
TIP: Confirm the connection is workable or not.

<Step1> Please select “Tools”→“Options”.

<Step2> Select “Device Tools”→”Device” in left block and select “Windows CE .NET Device” in Devices block.

<Step3> Press “Connect” button, your desktop will try to make a connection with UNO. If connection is okay, you will see the message “Device Connected” at the bottom of right side screen.

2. Make sure you choose the Windows CE .NET Device in the list. (Figure 2-12) Then from the Build menu, choose Build Solution to build the project.

3. From the Tools menu, choose Select Windows CE Device CPU. (Figure 2-13)
In the Dialog Box of **Select Windows CE CPU**, select **X86** from **Select Device Architechture** list, and click **Configure** button. (Figure2-14)
3. In this example, we use ActiveSync to download our project to devices. Start your Advantech CE Device, and connect the COM port of Desktop PC and the COM port of the CE Device with a 9 pin COM port cable. In CE Device, select Start->Programs->Communication->ActiveSync. Then you can see the connected icon on the right-bottom of the screen of your Desktop PC. (Figure 2-15)

![Figure 2-15](image)

4. From the *Debug* menu, choose *Start Without Debugging*. The Deploy dialog box shown in Figure 2-16 is displayed.

![Figure 2-16](image)

This dialog box lists the available devices that support the current project type. Select *Windows CE .NET Device*, and click the *Deploy* button. Visual Studio will now build your application and start the it on your CE Devices. (Figure 2-17)
3. Debugging a .NET application

It is absolutely vital for programmers to use tools to debug their code. Let us modified the demo above to make some errors for presenting how to debug a program.

1. Add the following statements in function button1_Click:
   ```csharp
   private void button1_Click(object sender, System.EventArgs e)
   {
       int a = 1;
       int b = 2;
       int c = a++ + b;
       System.Windows.Forms.MessageBox.Show( a + " + " + b + " = " + c );
       Application.Exit();
   }
   
   We want to show “a + b = c” in a MessageBox. However, we add an unwanted “++” after “a” in “int c = a + b”. Then the result should be as Figure3-1:

   ![Figure3-1](image)

   Figure3-1

2. Make the cursor in the line of “int a = 1;”, and press F9 in the keyboard( Figure3-2 ) to set breakpoint.

   ![Figure3-2](image)
3. From the Debug menu, choose Start. Select Windows CE .NET Emulator, and click the Deploy button in Deploy dialog box. Click the Exit button in the Form1 in Emulator. The debug window should appear. (Figure3-3)

```csharp
private void Button1_Click(object sender, EventArgs e)
{
    int a = 1;
    int b = 2;
    int c = a++ + b;
    MessageBox.Show(System.String.Format("c = {0}", c));
    Application.Exit();
}
```

(Figure3-3)

4. Add a, b and c to Watch1 window. (Figure3-4) You could see the current values of these variables. Press F10 could go to the next statement, F11 could step into the function (if the current statement calls functions). Then we find that “a” changed into 2 after executing “int c = a++ + b;”. We catch this bug and change this expression to “int c = a + b;”, and run this application again. The result is the same as what we expect. (Figure3-5)

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>0</td>
<td>int</td>
</tr>
<tr>
<td>b</td>
<td>0</td>
<td>int</td>
</tr>
<tr>
<td>c</td>
<td>0</td>
<td>int</td>
</tr>
</tbody>
</table>

(Figure3-4)
Figure 3-5